Realm v10.1.1 Release Notes

Release Date: 2020-11-27 // 6 months ago
  • 💥 Breaking Changes

    • None.

    ✨ Enhancements

    • None.

    🛠 Fixes

    • KAPT crash when processing a RealmObject referenced from another module (changed revealed after we started checking for embedded types). (Issue #7213, since v10.0.0).

    Compatibility

    • ⬆️ File format: Generates Realms with format v20. Unsynced Realms will be upgraded from Realm Java 2.0 and later. Synced Realms can only be read and upgraded if created with Realm Java v10.0.0-BETA.1.
    • 🚀 APIs are backwards compatible with all previous release of realm-java in the 10.x.y series.
    • Realm Studio 10.0.0 or above is required to open Realms created by this version.

    Internal

    • ⚡️ Updated to Realm Sync: 10.1.3.
    • ⚡️ Updated to Realm Core: 10.1.3.
    • ⚡️ Updated to Object Store commit: fc6daca61133aa9601e4cb34fbeb9ec7569e162e.