Google HTTP Client v1.42.3 Release Notes

Release Date: 2022-10-27 // about 1 month ago
  • 🐛 Bug Fixes

    • ➕ Add @CanIgnoreReturnValue to avoid errorprone errors (#1716) (cba2f82)

    Dependencies

    • ⚡️ Update actions/checkout action to v3 (#1719) (6b9585b)
    • ⚡️ Update dependency cachetools to v5 (#1732) (7d153d3)
    • ⚡️ Update dependency certifi to v2022.9.24 (#1734) (3b345df)
    • ⚡️ Update dependency charset-normalizer to v2.1.1 (#1738) (a3cbf66)
    • ⚡️ Update dependency click to v8.1.3 (#1739) (0b2c204)
    • ⚡️ Update dependency com.fasterxml.jackson.core:jackson-core to v2.13.4 (#1718) (394aa98)
    • ⚡️ Update dependency com.google.code.gson:gson to v2.10 (#1761) (7d15ad6)
    • ⚡️ Update dependency com.google.code.gson:gson to v2.9.1 (#1700) (5c17e2b)
    • Update dependency com.google.errorprone:error_prone_annotations to v2.15.0 (#1701) (0a2e437)
    • Update dependency com.google.errorprone:error_prone_annotations to v2.16 (#1755) (1126e53)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.3 (#1694) (f86112d)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.4 (#1698) (fdabd56)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.5 (#1703) (bdb8cbd)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.6 (#1722) (28ee333)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.7 (#1751) (af16206)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.8 (#1756) (9119d85)
    • ⚡️ Update dependency com.google.protobuf:protobuf-java to v3.21.9 (#1762) (02581b8)
    • 🚀 Update dependency gcp-releasetool to v1.8.8 (#1735) (f24c984)
    • ⚡️ Update dependency google-api-core to v2.10.1 (#1740) (eacf983)
    • ⚡️ Update dependency google-auth to v2.12.0 (#1741) (bfea196)
    • ⚡️ Update dependency google-cloud-core to v2.3.2 (#1736) (a333e1f)
    • ⚡️ Update dependency google-cloud-storage to v2.5.0 (#1742) (8335e66)
    • ⚡️ Update dependency google-crc32c to v1.5.0 (#1743) (3fd3292)
    • 📇 Update dependency importlib-metadata to v4.12.0 (#1746) (4658601)
    • ⚡️ Update dependency jeepney to v0.8.0 (#1747) (0866e4d)
    • ⚡️ Update dependency jinja2 to v3.1.2 (#1748) (1507e04)
    • ⚡️ Update dependency keyring to v23.9.3 (#1749) (55bcbd7)
    • ⚡️ Update dependency markupsafe to v2.1.1 (#1744) (a62cace)
    • ⚡️ Update dependency org.apache.felix:maven-bundle-plugin to v5.1.7 (#1688) (8bea209)
    • ⚡️ Update dependency org.apache.felix:maven-bundle-plugin to v5.1.8 (#1699) (fa578e0)
    • ⚡️ Update dependency protobuf to v3.20.2 (#1745) (3b0fc85)
    • ⚡️ Update dependency protobuf to v4 (#1733) (99457dd)
    • ⚡️ Update dependency pyjwt to v2.5.0 (#1728) (c285b9a)
    • ⚡️ Update dependency requests to v2.28.1 (#1729) (ee9fc81)
    • ⚡️ Update dependency typing-extensions to v4.3.0 (#1730) (f8980a4)
    • ⚡️ Update dependency zipp to v3.8.1 (#1731) (49477d4)
    • ⚡️ Update project.appengine.version to v2.0.6 (#1704) (b33a9c1)
    • ⚡️ Update project.appengine.version to v2.0.7 (#1711) (523a260)
    • ⚡️ Update project.appengine.version to v2.0.8 (#1723) (12a455c)
    • ⚡️ Update project.appengine.version to v2.0.9 (#1753) (d047334)

Previous changes from v1.42.2

  • 🐛 Bug Fixes