jjwt v0.11.5 Release Notes

  • 🚀 This patch release adds additional security guards against an ECDSA bug in Java SE versions 15-15.0.6, 17-17.0.2, and 18 (CVE-2022-21449) in addition to the guards added in the JJWT 0.11.3 🚀 release. This patch allows JJWT users using those JVM versions to upgrade to JJWT 0.11.5, even if they are unable to ⬆️ upgrade their JVM to patched/fixed JVM version in a timely manner. Note: if your application does not use these JVM 🔖 versions, you are not exposed to the JVM vulnerability.

    Note that the CVE is not a bug within JJWT itself - it is a bug within the above listed JVM versions, and the 🚀 JJWT 0.11.5 release adds additional precautions within JJWT in case an application team is not able to upgrade their JVM in a timely manner.

    🔒 However, even with these additional JJWT security guards, the root cause of the issue is the JVM, so it strongly ⬆️ recommended to upgrade your JVM to version 15.0.7, 17.0.3, or 18.0.1 or later to ensure the bug does not surface elsewhere in your application code or any other 🔒 third party library in your application that may not contain similar security guards.

    Issues included in this patch are listed in the JJWT 0.11.5 milestone.

    Credits

    🔒 Thank you to Neil Madden, the security researcher that first discovered the JVM vulnerability as covered in his Psychic Signatures in Java blog post. Neil worked directly with the JJWT team to provide these additional guards, beyond what was in the JJWT 0.11.3 🚀 release, and we're grateful for his help and collaboration in reviewing our fixes and for the additional tests he provided the JJWT team.